Michigan Online School - PowerSchool outage
Incident Report for ACCEL TSD
Resolved
System Affected
MOS PowerSchool instance.
Issue
PowerSchool was not loading.
Actions
Our vendor, PowerSchool, performed updates on their end restoring access to the system.
Posted Apr 28, 2023 - 21:50 UTC
Identified
System Affected
MOS PowerSchool instance.
Issue
PowerSchool not loading.
Actions
A ticket with our vendor, PowerSchool has been created and escalated. No ETA has been established.
Posted Apr 28, 2023 - 19:04 UTC
This incident affected: Learning Platform (Learning Platform - Powerschool).