Clever login issues
Incident Report for ACCEL TSD
Resolved
This incident has been resolved. Our Vendor, Clever, has restored access to Supplemental Programs such as, but not limited to IXL,i-Ready, Kahoot, and BrainPOP
Posted Apr 07, 2023 - 11:18 UTC
Update
DISRUPTION UPDATE

Systems Affected
Clever
Issue
Unable to login to Clever impacting ability to access Supplemental Programs such as but not limited to IXL, iReady, Kahoot, BrainPOP
Actions
Outage has been confirmed by our vendor, Clever. No ETA provided
Posted Apr 06, 2023 - 15:49 UTC
Identified
Systems Affected
Clever
Issue
Unable to login to Clever
Actions
Internal Teams have reached out to our vendor, Clever to escalate the login issues. No ETA provided
Posted Apr 06, 2023 - 14:48 UTC
This incident affected: Learning Platform (Learning Platform - Canvas).